korjian
Participant
  • 0
  • 1
  • 0
Registered since

Mar 10, 2021

Safety protection mode

I bought my soundwear companion speaker a couple of years ago and everything was perfect.

I stopped using it for a 3 4 months then when i tried to charge it again it didnt charge at all.

One white light blinked once as soon as i plug it in but that is all that happens.

I read the owners manual and saw that it might have gone into safety protection mode.

I contacted the service center and they said nothing can be done.

Im pretty sure that there is a solution but the service center here in lebanon is worthless.

So please i need help

1 REPLY 1
Jeff_G
Moderator

Re: Safety protection mode

Hey Korjian! 

 

Thanks for posting.

 

I'm sorry to hear you've had issues with your speaker. Regrettably, we're unable to offer service via the Community. I'm happy to discuss troubleshooting with you. 

 

Did the center explain why nothing could be done with the speaker? Are they not able to offer repairs? 

 

With regards to troubleshooting, I recommend trying a different USB cable and charger. I also recommend checking for firmware updates. You can do this by visiting this link on a computer.

 

Thanks. 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!