Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Apr 27, 2020

Bose Companion 5 Sound Pod issues

I've read that many folks have various issues with their sound pod, and for me I'm talking specifically about the one I got with my Bose Companion 5.

 

All of a sudden, the sound goes up and down on my speakers. After finding the same thing to happen on multiple computers, I finally got it working right - only to realize that the volume control stopped working.

 

When I plugged and unplugged things, I got the volume control on the pod to work again, and the sound problems resumed.

 

I'm led to believe that there is dust or something in my sound pod and it can't be cleaned.

Can I get a new one from Bose?

 

My speakers seem to work without the sound pod, but this seems ridiculous that this piece can cause issues.

 

I'm willing to buy a new pod but don't see one for sale at Bose. Please advise.

1 REPLY 1
Highlighted
Moderator

Re: Bose Companion 5 Sound Pod issues

Hi bsumner,

 

Thanks for posting and welcome to the community!

 

You've already done a lot of great troubleshooting with this by the sounds of it, so thank you for doing that and letting us know! Testing with multiple computers and isolating the control pod are both great places to start.

 

As it does seem down to just the control pod causing the issue, I would agree with you. It does sound like the control pod does need replacing at this point. The best way to get hold of a new one is to get in touch with your local support team HERE. Just select your country and scroll down to the Contact Us option at the bottom of the page.

 

I hope this helps!

 

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!