• 0
  • 1
  • 0
Registered since

Jan 12, 2021

No power - Bose Companion 20 Multimedia Speaker System

Bose Companion 20 Multimedia Speaker System


I am getting no power to the speaker system and the power indicator on the control pod does illuminate when I touch the pod to power up the unit. 


I have tried resetting the system by unplugging from the power source and computer for 30 seconds followed by a full reboot.  I have tried multiple power outlets.  I have tried using the system with both my desktop Mac Pro and my Macbook Pro laptop and get the same results with both.  I also plugged my old Altec Lansing speaker system into the Mac Pro, and they work fine.  Voltage meter indicates power cord is carrying electricity. 


System is about four years old but hasn't been used for approximately 10 months.


Any advice would be greatly appreciated. 




Re: No power - Bose Companion 20 Multimedia Speaker System

Hey Jason Y, 


Thank you for reaching out to us and welcome to the Community! 


These are some great troubleshooting steps! Thank you for trying them. I'm sorry to hear that they have not resolved your issue. At this point, you have tried all the troubleshooting steps we would normally recommend for your issue. Therefore, it could have developed a hardware fault. I would recommend reaching out to our team to see if they will be able to assist you. You can do this by clicking the LINK HERE, selecting your country, and scrolling down to 'Contact Us'. We will do all we can to help you! 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!