Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Oct 8, 2020

PS38 Sub and AV28

I had this system for a while now and was working properly until recently. I’ve manage to repair my AV28 console by replacing the HDD inside. Now, no matter how many times I try to reconfigure the speakers, no sounds can be heard when I use the PS38. I have two small speakers which I did used in the AV28, but the sounds are very faint and at least I know the speakers and the console indeed do work. 

 

I really hope that the PS38 is still usable and not dead. I tried everything. I even have a Boselink and see if it that had anything to do with it. I guessing that there is a mechanical problem with the PS38. Maybe could it be the phone line is damaged. I also noticed the power supply cord is at 125v and not the recommend 120v. 

 

Any help or advice would be great. Thanks!

1 REPLY 1
Highlighted
Community Manager

Re: PS38 Sub and AV28

Hi cbstacker, thanks for your message.

 

While we're able to assist with troubleshooting support via the Bose Community, Bose systems should not be manually repaired or serviced by the end-user. All required services should be conducted by an authorized Bose service facility. To contact your local team, please click HERE. Select your country, and use the "Contact us" button at the bottom of the page for assistance. 

 

As we're unable to help with this request via the Bose Community forums, we will be locking this thread.

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!