• 0
  • 1
  • 0
Registered since

Sep 4, 2020

Soundlink Air won't turn on

Hello, my 2012 Soundlink Air will not turn on, at all. It's plugged in at the socket but has no lights on. I've tried using the power button on the remote and nothing. I've put a new battery in the remote. Any suggestions gratefully received. Thank you.


Re: Soundlink Air won't turn on

Hi RachelAJ,


Welcome to the Community, thanks for joining us!


It sounds like you've been doing some great troubleshooting with this already, so thank you for doing that and letting us know! Attempting to use the speaker while connected to an outlet, and changing batteries in the remote are both really useful steps to take to resolve this.


If you aren't seeing any lights at all when plugged into the outlet, it does sound like the speaker is not receiving power correctly. Have you tried plugging it into any other power outlets? If not it would definitely be worth doing so to make sure the outlet is not causing the issue.


If it still will not turn on when connected to another outlet, the next thing to do would be to reach out to your local support team to discuss the service options for your speaker. You can find the contact information for your local team at this link, by selecting your country/region and then the 'Contact Us' option at the bottom of the page.


I hope this helps!

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!