Quiet Contributor
  • 1
  • 1
  • 0
Registered since

Aug 9, 2019

re: Bose Companion 5 stops working and have to reboot - how can I fix this?

I recently bought a new Macbook Pro (15 inch, 2018 version) and moved my iTunes libarary and Bose Companion 5 multimedia speakers over to it. The Bose speakers sound GREAT, but...the speakers stop working after a while and I have to reboot my compter to get them going again. WHAT A PAIN! Evidently this is an issue for everybody trying to use the Companion 5 speakers with the new Macs because there are lots and lots of post threads already started in this BOSE community and evidently this issue is being ignored by Bose (I could not find any suitable fixes posted). Note: I tried disconnecting the power to the speakers for 10 minutes and simulatanously rebooting my computer - this was not a permanent fix; tried hooking up an AUX jack connection directly to the volume wheel -  is not a fix because the sound quality is lame when compared to what I get when using the USB connection; looked at the settings in the MIDI program found in the Utility Folder - nothing wrong with the settings there - they match what others have suggested in this forum). This is a software driver issue and since this has been going on for a while, it seems like Bose has cut off supporting this product since they stopped selling it in 2018 - it doesn't seem there is a fix coming. Is this true? No fix coming? Should I put my speakers in the trash? (or sell them to a Windows user where this problem doesn't happen?). It certainly doesn't make me want to visit a Bose store any time soon to buy any more Bose products. These wonderful speakers are useless to me this way and I am searching for a solution so that I can keep enjoying them on my new Mac. Many thanks to anyone that has a fix that actually works!!!

Animated Arbiter
  • 14
  • 209
  • 11
Registered since

Mar 7, 2019

Re: re: Bose Companion 5 stops working and have to reboot - how can I fix this?

Have you ruled out the problem might be with your mac? If so what steps have you done to verify it isn't your mac?