• 0
  • 1
  • 0
Registered since

Oct 12, 2020

AWRCC1 will not eject CD or make any sounds

My Wave has a CD in it that it will not eject.  When eject is requested, it first displays "Ejecting", and then it displays "Disc Error".  If I hit the eject button again it will begin spinning and reading the disc, and will actually display track and time of the song as if it's playing, but no sound comes out.  I can move through tracks per the display and stop the CD, but again, when I request eject, I get "disc error" displayed.  I can also switch to the radio and see stations displayed, but no sound comes out.  I have the cover off and see the two fences in front of the CD, but I can't move them.  Unplugging and resetting does not change anything.  I suspect that if I can get the CD to eject, I'll get sound from the radio and any other CD's that I may be able to load back in.  Everything worked perfectly before this happened.  Any suggestions?




Re: AWRCC1 will not eject CD or make any sounds

Hey Mark, 


Thank you for reaching out to us! 


I'm sorry to hear of the issues you are experiencing with your system. I'll be happy to help! 


I can see you have tried a reset. I would recommend performing this again then when unplugged, flip the system upside down and tap on the bottom of the system. Hopefully, this should eject your CD. 


Let me know how you get on! 

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!