Highlighted
Kubiske
Silent Starter
  • 0
  • 1
  • 0
Registered since

May 31, 2019

CD will not eject from Wave II unit

We have a Wave II unit. The 5-disc part of the unit suddenly stopped playing and ejecting CDs.

 

We have tried rapping in the hopes of shaking something loose to get the discs out. No joy. We have also turned off the unit -- pulling the plug -- overnight and tried again. No joy!

 

Do you have any other suggestions? Or does this need to be sent in for repairs>

 

The unit was purchased about 8 years ago.

1 REPLY 1
Moderator

Re: CD will not eject from Wave II unit

Hi Kubiske, 

 

Thanks for your post and welcome to the community. I am sorry to hear that you are having issues with your Wave System, however I would love to help. 

 

Firstly, I would recommend that you ensure that you have the correct multi-disc changer selected when attempted to eject the disk, I would also recommend that you perform a product reset on the system this can be done via: 

 

  • Turn the system off.
  • Disconnect the power cord from the back of the WMS. Wait 30 seconds.
  • Reconnect the power cord.
    • If there is a disc in the system that was not previously ejected, the disc should eject. The disc will automatically reload if it is not removed within 10 seconds
  • Retest the system.

 

If the disc is still tuck in the system I would recommend that you turn the system upside down and attempt to eject the disc again. If the issue still continues after these steps, I would highly recommend getting in touch with our Customer Service Team via clicking this link. Then kindly scroll and select your region, once this is done please scroll to Contact Us. The team will be on hand and ready to help.

 

Please update me on the result of these steps. 

 

Kind Regards, 

Hector B - Community Support