TZ
Participant
  • 0
  • 2
  • 0
Registered since

Feb 17, 2021

Remote on & off not working - everything else is!

I got an old Bose Wave radio AWRCC2 from my parents several years ago. Works great, good sound. Remote has worked fine until recently - and still works fine except the on/off button no longer controls the radio. Just changed batteries last week so that's not it. Any ideas?

3 REPLIES 3
Jeff_G
Moderator

Re: Remote on & off not working - everything else is!

Hello TZ, 

 

Thanks for posting!

 

It's possible the remote may need replacing if changing the batteries did not resolve the issue. Have you tried resetting the system to see if that makes a difference? To reset, unplug from power for around 30 seconds, then reconnect it to power.

If you still have issues, visit this link to seek local support to obtain a new remote. 

 

Thanks!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
TZ
Participant
  • 0
  • 2
  • 0
Registered since

Feb 17, 2021

Re: Remote on & off not working - everything else is!

Thanks; had tried resetting. Will work on getting a new remote.

Silvervifer
Participant
  • 0
  • 1
  • 0
Registered since

Feb 20, 2021

Re: Remote on & off not working - everything else is!

Similar problem, same device, but I get 'Please Wait' when using the 'power on' on the remote. Have reset by unplugging the power cord and the system reset in the setup menu. I get 'Please Wait' when the unit is trying to power on the radio, CD or Aux. When it finally turns on, it all works wonderfully. So, as the remote is controlling the device (once on) it can't be the remote that is at fault. So, what else can be wrong with the device? It's as if the amplifier itself won't power up. I also see a number of other posts regarding 'Please Wait'. If this is such a common problem, why isn't the fault/remedy known?