Wave System Won't Eject or Play Brand New CD

SOLVED
Highlighted
Audible Advocate

Wave System Won't Eject or Play Brand New CD

I had the power go out earlier, and when it came back on the CD that was in the player at the time ejected just fine.  So I decided to unwrap and play the brand new music CD I received a couple days ago...and no go.  The player said it was unplayable and disc error, and won't let go of it, tho it does spin it judging by a new grindy noise.  I tried the reset solution twice, and the 'tap on the bottom' solution suggested by a mod in another thread here, but no dice.  Its just taunting me with 'Disc Error' and not giving it up.  And I don't see any manual eject holes you used to be able to stick the end of a paperclip in.

 

Please help!

--Zhora

1 ACCEPTED SOLUTION
Author Accepted Answer selected by ZhoratheWolverbabe

Accepted Solutions
Audible Advocate

Re: Wave System Won't Eject or Play Brand New CD

I have an update.  Apparently when I did the flip-and-tap-the-bottom solution, I didn't hit it hard enough.  Just flipped it and smacked it good this time after noticing the very edge of the CD was visible (but not enough to grasp), then hit Eject and it stuck out the CD a couple millimeters more, allowing me to grasp the edge and pull it out.  Then I tried another CD (an old CD-R as I didn't want to risk any of my bought CDs just in case) and it worked fine.  Everything else was working just fine, btw.

 

Should I expect that this will be a continuing problem?  I got it as a replacement in that sweet sweet trade-in deal Bose had back in 2012, I'd hate to lose it so soon.

1 REPLY 1
Audible Advocate

Re: Wave System Won't Eject or Play Brand New CD

I have an update.  Apparently when I did the flip-and-tap-the-bottom solution, I didn't hit it hard enough.  Just flipped it and smacked it good this time after noticing the very edge of the CD was visible (but not enough to grasp), then hit Eject and it stuck out the CD a couple millimeters more, allowing me to grasp the edge and pull it out.  Then I tried another CD (an old CD-R as I didn't want to risk any of my bought CDs just in case) and it worked fine.  Everything else was working just fine, btw.

 

Should I expect that this will be a continuing problem?  I got it as a replacement in that sweet sweet trade-in deal Bose had back in 2012, I'd hate to lose it so soon.