Highlighted
Silent Starter
  • 0
  • 2
  • 0
Registered since

May 21, 2020

Wave system w/Multi CD Changer

I have a 9 year old system that has functioned perfectly up until a few months ago. The Multi Changer has started making clicking noises when I play the cd's. It has gotten so bad that I can no longer hear anything other than the click.

Is it just old and done, or is there something that I can do to fix it.

Thank you.

5 REPLIES 5
Highlighted
Moderator

Re: Wave system w/Multi CD Changer

Hi MLY,

 

Thank you for posting and welcome to the community!

 

To be able to help with any fixes for your disc changer I do have a couple of questions to gather a bit more about your setup and what is happening with it.

 

Firstly, can you let me know which model of Wave system and the multi-disc changer you have? If you are unsure you can use the Product Identifier to double-check.

 

Also, the noise you are hearing from the disc changer, is this clicking coming from the disc changer itself of playing through the speaker as part of the audio?

 

Do you get this noise with any CDs in any drive on the disc changer, or do only certain CDs in certain disc drives cause this noise?

 

I look forward to hearing more from you!

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.
Highlighted
Silent Starter
  • 0
  • 1
  • 0
Registered since

May 23, 2020

Re: Wave system w/Multi CD Changer

I have similar problem with my ancient sound wave system - still works fine but the multi changed won’t. A disc that plays fine in disc1 shows as disc error in all of the multi changer slots, and reading the disc is accompanied by loud clicks in disc 2.

Highlighted
Silent Starter
  • 0
  • 2
  • 0
Registered since

May 21, 2020

Re: Wave system w/Multi CD Changer

The noise is coming from the CD player, not the CD, and I can’t hear the CD when the noise is happening. Multi CD changer.

Thanks for your reply Keith.

Highlighted
Community Manager

Re: Wave system w/Multi CD Changer

Hey AmiBee and MLY,

 

It sounds like there may be a hardware fault with the speakers. Have you tried resetting the systems? To do this, simply disconnect the power cord from the back of the changer or from the wall outlet for 30 seconds. Then, reconnect back to test.

 

If issues do persist, please reach out to Bose support in your region directly to explore service options. Click HERE, select your location, and use the "Contact us" button at the bottom of the page. Please note that due to the age of some systems, we may no longer be able to repair or exchange them due to stock/component availability. Our local support will be able to give you the most accurate and up to date information. 

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.
Highlighted
Silent Starter
  • 0
  • 1
  • 0
Registered since

Jun 9, 2020

Re: Wave system w/Multi CD Changer

Same problem as AmiBee

Have tried

1. Unplugging system

2. Resetting system

3. CD disc clean