Highlighted
Silent Starter
  • 0
  • 1
  • 0
Registered since

May 16, 2020

wave soundtouch pedestal

I cannot express the level of frustration this morning after wanting to stream music to my Wave system and discovering . . for the third time now. . . that the pedestal was not working.  Having returned the original for repair, received back, returned again for repair, received back, and now the third failure . . I am well versed in the setup and diagnostic procedures. I frankly can't believe this lack of quality from Bose product.  My suspicion is that the same pedestal is being repaired and there is a recurring problem causing the repeating failure.  Perhaps a brand new replacement is the answer if true.  Has anyone else had similar experiences?  I may be an outlier.   Any help is appreciated.

 

1 REPLY 1
Highlighted
Moderator

Re: wave soundtouch pedestal

Hi @rjeswald,

 

Thank you for taking the time to post. I can understand your frustration completely - this shouldn't be a reoccurring theme.

 

My best advice would be to contact local support once more and explain that your pedestal has been serviced multiple times and is experiencing the same problem. That way, the team can look into alternative ways of finding a resolution to the issue you're experiencing.

 

Please let me know if you have any other questions I could answer for you.

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.