cancel
Showing results for 
Search instead for 
Did you mean: 

Who also had this issue

Andreighya
Participant
  • 0
  • 2
  • 0
Registered since

Jun 30, 2021

Soundlink Firmware update won't install on Mac (Error: needs updating by developer)

Bose product name: Bose Soundlink III

Country: Australia

Firmware Version: Unsure, have never updated

App Version: Unsure

What devices were you using that were affected and what version are they on: All my devices - Mac Air, iPhone 7

Detailed description of the issue and steps to reproduce:

At random, the Bose will drop the bluetooth connection, often multiple times in a row, sometimes minutes, sometimes hours apart. Sometimes it becomes impossible to connect to, no matter how many times you try. Sometimes it's completely find and no issues at all, what a mystery!

 

Where do you run into the issue?
Sporadically. When the issue is occurring, it usually persists for a day or so, then goes away for days or weeks, then returns.

 

When did you start to experience the issue? Did it work correctly previously? 

In the last year or so, worked fine previously.

 

Any troubleshooting steps you took:

Turned it on and off, set it to Aux, then back to pairing. Tried connecting multiple times, with different devices.

I was keen to try a firmware update, but the software on your website is not up to date enough for Mac Catalina or Mac Big Sur, so I can't install it (https://www.bose.com.au/en_au/support/article/soundlink_wireless_mobile_download.html)

 

Is it possible to get the Bose Soundlink firmware software updated by the developers so that it works on Mac OSX?

It no longer can be installed on Catalina (2019) or Big Sur (2021) (have tried on two computers). The warning comes up on Mac "The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information." I have tried manually opening it from within the package folder, but it is no longer possible to open out of date software on Macs, so I'm not sure what to do.

I've tried chatting to Bose support on the website, but they told me to go and get a Windows laptop instead of a Mac, which isn't so helpful haha

 

Who also had this issue